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ISE Quick Start Tutorial with VHDL 
กอนที่จะปฏิบัติตามเอกสารนี้ ทานจะตองทําการติดตั้งโปรแกรม ISE WebPACK และ 

ModelSim กอน หากวายังไมไดติดตั้งขอตดิตั้งโดยดูวิธีการจากเอกสาร “วิธีการติดตั้งโปรแกรม” 

ภาพรวมของ Tutorial 
Tutorial นี้ดัดแปลงมาจาก ISE Quick Start Tutorial ของบริษัท Xilinx โดยดัดแปลงใหใช

กับบอรดฝกหดัการใชงาน CPLD Explorer XC9572 ของบริษัท Apex Instrument 

Tutorial นี้มคีวามมุงหมายใหเปนแบบฝกหัดอนัแรกสาํหรับผูเร่ิมตนการเขียนโปรแกรมเพื่อ
ออกแบบวงจรดิจิตอลดวยภาษา VHDL ซ่ึงเปนภาษามาตรฐานที่นิยมใชงานกนัมาก Tutorial นี้จะ
สอนวิธีการสรางโปรเจกโปรแกรมนับ (counter) ขนาด 4 บิต โดยนับสัญญาณที่กําเนิดจากสวิทช
กดติดปลอยดบั และมีอีกสวทิชอีกอันหนึ่งเปนตัวกําหนดวาใหนับขึ้นหรือนับลง 

การเริ่มตนการใชงาน 
ที่ Start Menu ใหเลือก Start → All Programs → Xilinx ISE 7.1i → Project Navigator 

การสรางโปรเจกใหมในโปรแกรม ISE 
1. ที่เมนูบารเลือก File > New Project โปรแกรมเปดหนาตาง New Project ขึ้นมา 
2. หนาตางแรกใหตั้งคาดังตอไปนี ้แลวคลิกปุม Next 

• Project Location: (กําหนด Directory สําหรับเก็บโปรเจกที่จะสรางขึ้น) 
• Project Name: Counter (โปรแกรมจะใสช่ือ Subdirectory ช่ือ Counter ใหโดยอัตโนมตัิ) 
• Top-Level Module Type: HDL 
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3. โปรแกรมจะแสดงหนาตางใหตั้งคาคุณสมบัติ ใหตั้งคาดังตอไปนี้ แลวคลิกปุม Next 
• Device Family: XC9500 CPLDs 
• Device: xc9572 
• Package: PC44 
• Speed Grade: -15 
• Top-Level Module Type: HDL 
• Synthesis Tool: XST (VHDL/Verilog) 
• Simulator: ModelSim 
• Generated Simulation Language: VHDL 

 
4. โปรแกรมจะทําแสดงหนาตางเพื่อใหสรางโปรแกรม (source) ใหม แตเนื่องจากเราจะสรางใหม
ภายหลัง ตอนนี้ใหคลิกปุม Next เลย 
5. คลิกปุม Next โปรแกรมจะทําแสดงหนาตางเพื่อใหเลือกโปรแกรม (source) ที่มีอยูเดิม  คลิกปุม 
Next 
6. โปรแกรมจะแสดงสรุปขอมูลของโปรเจกใหมที่จะสรางขึ้น คลิกปุม Finish 
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การสราง VHDL Source 
โปรแกรมนับจะมีสองสัญญาณอินพุทไดแก CLOCK และ DIRECTION โปรแกรมจะนับขึ้น

หรือลงขึ้นอยูกับสัญญาณ DIRECTION และมีสัญญาณเอาทพุทเปนบัสขนาด 4 บิต เรียกวา 
COUNT_OUT 

1. จากเมนูบารเลือก Project > New Source โปรแกรมจะเปดหนาตาง New Source ขึ้นมา 
2. เลือก VHDL Module และใสช่ือไฟลวา Count 
3. ตรวจทานวามีเครื่องหมายถูกในชอง Add to project 
4. คลิกปุม Next 

 
5. กําหนด Port สําหรับ VHDL Source (ดังแสดงในรูป) เมื่อเสร็จใหคลิกปุม Next 

• ในคอลัมน Port Name ในแตละแถวใหพมิพ CLOCK, DIRECTION และ COUNT_OUT 
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• ในคอลัมน Direction ใหเลือกวาแตละ Port เปน input, output หรือ inout  สําหรับ CLOCK 
และ DIRECTION ใหเลือก in และ สําหรับ COUNT_OUT เลือก out 

• เพื่อกําหนดวาพอรท COUNT_OUT เปนบัสขนาด 4 บิต ใหเลือก 3 สําหรับคอลัมน MSB 
(Most Significant Bit) และ 0 ในชอง LSB (Least Significant Bit) 

 
6. โปรแกรมจะแสดงสรุปขอมูลของ Source ใหมที่จะสรางขึ้น คลิกปุม Finish 
 

 
7. โปรแกรมจะทําการเปดไฟล Count.vhd ที่สรางขึ้นมาใหมโดยอัตโนมัติ ถาไฟลยังไมไดถูกเปด
ใหดับเบิลคลิกที่ไฟล Count.vhd ในหนาตาง Sources in Project เพื่อเปดไฟลนี้ขึ้นมา 

ไฟล Count.vhd จะประกอบดวย 

• Header information. 
• Library declaration and use statements. 
• Entity declaration และ Architecture statement. 

8. ในสวน header ใหใสขอมูลตอไปนี้ 
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• Design Name: Count.vhd 
• Project Name: Counter 
• Target Device: XC9572-15PC44 
• Description: This is the top level HDL file for an up/down counter. 
• Dependencies: None 

หมายเหต:ุ แมวาการเขียนขอมูลสวนนี้จะไมจําเปน แตวาก็เปนขอควรปฏิบัติในการเขยีนโปรแกรม 

การใช Language Templates (VHDL) 
โปรแกรม ISE มี Template โปรแกรมในภาษาตางๆ (ABEL, UCF, Verilog, VHDL) สําหรับ

วงจรที่ใชบอย  ใน Tutorial นี้จะใช Template สําหรับวงจร Up/Down Simple Counter  ในการจะ
เรียกใช Template ใหทําดังตอไปนี ้

1. เลือก Edit > Language Templates 
2. คลิกที่เครื่องหมาย “+” เพื่อที่จะเปดโฟลเดอรตอไปนี ้
VHDL > Synthesis Constructs > Coding Examples > Counters > Binary > Up/Down Counters > 
Simple Counter 
3. คัดลอกโคด Language Template มาจากหนาตางดานขวา แลววางลงบนไฟล Count.vhd ระหวาง 
คําสั่ง begin และ end ของ architecture 

 



ISE Quick Start Tutorial with VHDL  6 

ผศ.ดร. อิทธิโชติ จักรไพวงศ  VHDL Tutorial 
คณะวิศวกรรมศาสตร มหาวิทยาลัยมหิดล   Last Updated 11/12/2006 

4. แทนชื่อที่อยูในกรอบเครื่องหมาย <> ดวยช่ือพอรทซึ่งไดกําหนดไวตอนที่สรางไฟล VHDL  
แมวาภาษา VHDL จะไมสนใจตวัอักษรใหญเล็ก แตกข็อใหเขียนใหตรงกันเพื่อความเปนระเบยีบ
เรียบรอย ใหทาํการแกไขดังตอไปนี ้
แทนคําวา <clock> ดวย CLOCK 
แทนคําวา <count direction> ดวย DIRECTION 
แทนคําวา <count> ดวย COUNT_OUT 
5. ปดหนาตาง Language Template 

การแกไข VHDL Source เพิ่มเติม 
1. ในไฟล VHDL โปรแกรมจะไมยอมใหอานคาจากพอรทที่ถูกกาํหนดใหเปนเอาทพุทโดยตรง 
ดังนั้นจึงตองทําการกําหนดตัวแปรชัว่คราวที่เก็บคาของเอาทพุทเอาไว  เราจะทําการประกาศตวั
แปรชื่อ count_int ใหเปนตวัแปรชั่วคราวนี้ โดยการประกาศดังตอไปนี้ใต architecture declaration 
และเหนือคําสั่ง begin อันแรก 

signal count_int : std_logic_vector(0 to 3) := "0000"; 
 

2. ใหแทรกคําสั่งเพื่อเรียกใชตัวแปร count_int ที่ตําแหนงตอไปนี ้
if DIRECTION =’1’ then 

count_int <= count_int + 1; 
else 

count_int <= count_int - 1; 
end if; 

3. ใตคําสั่ง end process ใหเพิ่มคําสั่งวา 
COUNT_OUT <= count_int; 

4. บันทึกไฟลโดยเลือก File > Save จากเมนูบาร 
5. เมื่อแกไขเสร็จทั้งหมดแลวใหตรวจทานวาไฟล Count.vhd ควรมีคําสั่งดังนี ้

architecture Behavioral of Count is 
 
signal count_int : std_logic_vector(0 to 3) := "0000"; 
 
begin 
 
 process (CLOCK)  
 begin 
    if CLOCK='1' and CLOCK'event then 
   if DIRECTION ='1' then 
    count_int <= count_int + 1; 
   else 
    count_int <= count_int - 1; 
   end if; 
    end if; 
 end process; 
 
 COUNT_OUT <= count_int; 
 
end Behavioral; 
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การตรวจสอบความถูกตองของโปรแกรมที่สรางขึน้ 
เมื่อทําการสรางไฟล VHDL ขึ้นมาเรียบรอยแลว ขั้นตอไปจะตองทําการตรวจสอบความถูกตอง 
โดยใหทําตามขั้นตอนตอไปนี้ 
1. เลือกไฟล Count.vhd ในหนาตาง Source in Projects โปรแกรมจะทําการแสดง Process ที่
เกี่ยวของกับ source นี้ในหนาตาง Processes for Source 

 
2. ในหนาตาง Processes for Source คลิกเครื่องหมาย “+” หนาคําวา Implement Design > 
Synthesize-XST 
3. ดับเบิ้ลคลิกที่ Check Syntax เมื่อการตรวจสอบเสร็จจะมีเครื่องหมายแสดงผลการตรวจสอบ
แสดงอยูหนาชื่อ 

• ถามีเครื่องหมายถูกสีเขียว แสดงวาโปรแกรมถูกตอง โดยไมมีคําเตือน 
• ถามีเครื่องหมายกากบาทสแีดง แสดงวาโปรแกรมมีขอผิดพลาด 
• ถามีเครื่องหมายตกใจสีเหลือง แสดงวาโปรแกรมถูกตอง แตมีคําเตือนเกิดขึ้น 
• ถามีเครื่องหมายคําถามสีสม แสดงวาโปรแกรมถูกแกไขหลังจากการตรวจสอบครั้งสุดทาย

และควรที่จะตองทําการตรวจสอบอีกครั้ง 
4. มองในแท็บ Console ของหนาตาง Transcript ดานลาง เพื่อดูผลการตรวจสอบ 
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การจําลองการทํางาน (Design Simulation) 

การสราง Test Bench สําหรับการ Simulation 
ในสวนนี้เราจะทําการสราง Test bench waveform ซ่ึงจะเปนการจําลองสัญญาณอินพุทเพื่อ

ใชในการ Simulate การทํางานของโปรแกรม เราจะตองใช Test bench waveform รวมกับ 
Simulator เพื่อสรางเอาทพุทเพื่อจะดวูาโปรแกรมทํางานตามที่ตองการหรือไม  เราจะใช Waveform 
Editor ในการสรางไฟล Test bench waveform (TBW) 

1. เลือกไฟล Count.vhd ในหนาตาง Sources in Project 

 
2. สราง Source ใหม ที่เมนูบารเลือก Project > New Source 
3. เลือก Test Bench Waveform และพิมพช่ือ Testbench ในชอง File Name 
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4. คลิกปุม Next 
5. หนาตางแสดงเพื่อใหเลือกไฟลจะใชในการทดสอบ ใหเลือก count แลวคลิกปุม Next 

 
6. คลิกปุม Finish 
7. โปรแกรมจะแสดงหนาตาง Initialize Timing ซ่ึงเราจะตองกําหนดคาเริ่มตนของสัญญาณที่จะใช
ทดสอบ ใหตั้งคาดังตอไปนี ้

• Clock Time High: 20 ns. 
• Clock Time Low: 20 ns. 
• Input Setup Time: 10 ns. 
• Output Valid Delay: 10 ns. 
• Initial Offset: 0 ns 
• Global Signals: PRLD (CPLD) 

หมายเหต:ุ เมื่อคลิกที่ชอง PRLD (CPLD) ชอง Initial Offset จะเปลี่ยนเปน 100 ns โดยอัตโนมัต ิ
• Initial Length of Test Bench: 2000 ns 
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8. คลิกปุม OK เพื่อเปด Waveform Editor 

 
แถบสีฟาในแถวของ DIRECTION เปนตําแหนงการเปลี่ยนสัญญาณอินพุทซึ่งเปนไปตาม Input 
Setup Time ที่ไดกําหนดคาในหนาตาง Initialize Timing กอนหนานี้  ซ่ึงในที่นีข้อใหสังเกตวา
ตําแหนงสีฟานี้จะอยูที่ตําแหนง Rising edge ของสัญญาณ CLOCK 
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9. ในที่นี้เรามอิีนพุทที่สามารถเปลี่ยนไดเพียงหนึ่งตัว กค็ือพอรท DIRECTION  ใหลองเปลี่ยน
สัญญาณของพอรท DIRECTION ดังตอไปนี ้

• กดที่แถบสีฟาที่ตําแหนงประมาณ 300 ns ใหสัญญาณเปลี่ยนจากต่ําไปสูง 
• กดที่แถบสีฟาที่ตําแหนงประมาณ 900 ns ใหสัญญาณเปลี่ยนจากสูงไปต่ํา 
• กดที่แถบสีฟาที่ตําแหนงประมาณ 1400 ns ใหสัญญาณเปลี่ยนจากต่ําไปสูง 

10. ที่เมนูบาร คลิกที่ File > Save เพื่อจัดเกบ็ Waveform ที่เพิ่งสรางขึ้น ใหสังเกตวาไฟล 
Testbench.tbw จะเพิ่มขึน้มาในหนาตาง Sources in Project 

 
11. ปดหนาตาง Testbench.tbw 

การสราง Expected Results ใหกับ Testbench Waveform 
ในขั้นตอนนี้เราจะสราง Expected Results หรือผลลัพธที่คาดวาจะไดใหกับ Testbench เมื่อ

ใหอินพุทตามที่ไดกําหนดไว  ขั้นตอนนี้เพื่อนําผลที่ไดมาเทียบกับผลที่ไดจากการ Simulate ซ่ึงจะมี
ประโยชนในการทํา Simulate Post-Place & Route HDL Model เพื่อเทียบผลวาโปรแกรมทํางาน
ตามที่ไดคาดไวหรือไม   ในการสราง Expected Results สามารถทําไดโดยกําหนดเองหรือวาให
โปรแกรมสรางใหโดยอัตโนมัติก็ได   การใหโปรแกรมสรางใหโดยอัตโนมัติทําไดดังนี้ 

1. ใหเลือกไฟล Testbench.tbw ในหนาตาง Sources in Project  เมื่อเลือกแลวจะมี Processes ช่ือ 
ModelSim Simulator ปรากฎอยูในหนาตาง Processes for Source 
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2. ในหนาตาง Processes for Source ใหดับเบิ้ลคลิกที่ Generate Expected Simulation Results 
3. โปรแกรมจะแสดงหนาตาง Expected Results ใหคลิกปุม Yes เพื่อวางผลลัพธใน Waveform 
editor 

 
4. คลิกที่เครื่องหมาย “+” เพื่อแสดงแตละบิตของบัส COUNT_OUT จะได Expected Results ดัง
แสดงในรูป 
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5. ที่เมนูบาร คลิก File > Save เพื่อบันทึก Waveform 
6. ปด Waveform Editor 

Simulating the Behavioral Model ดวยโปรแกรม ModelSim 
เนื่องจากเราไดทําการติดตั้งโปรแกรม ModelSim กอนหนานีแ้ลว เราจะสามารถทําการ Simulate 
การทํางานของโปรแกรมไดโดยการเรียกใชโปรแกรม ModelSim ผาน Processes ในโปรแกรม ISE  
ใหปฏิบัติดังตอไปนี ้
1. ใหเลือกไฟล Testbench.tbw ในหนาตาง Sources in Project  เมื่อเลือกแลวจะมี Processes ช่ือ 
ModelSim Simulator ปรากฎอยูในหนาตาง Processes for Source 
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2. ในหนาตาง Processes for Source  ใหดับเบิ้ลคลิกที่ Simulate Behavioral VHDL Model   
โปรแกรม ModelSim จะถูกเปดขึ้นเพื่อทําการ Simulation  เมื่อทําเสร็จเรียบรอยจะไดผลการ 
Simulation 
3. ใหเลือกซูมดูผลการ Simulation โดยคลิกขวาที่พื้นที่กลางหนาตาง wave-default เลือก Zoom 
Range 

 
4. โปรแกรมใหแสดงหนาตาง Wave Zoom ใหเลือก Start: 300 ns และ End: 900 ns 

 
5. โปรแกรมจะแสดงผลการ Simulation ในชวง 300 ns ถึง 900 ns ดังแสดงในรูป 
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6. ปดโปรแกรม ModelSim 

การสรางไฟล Constraints 
1. เลือกไฟล Count.vhd ในหนาตาง Sources in Project 
2. ในหนาตาง Processes for Source คลิกที่เครื่องหมาย “+” หนา User Constrints เพื่อขยายรายการ 
3. ดับเบิ้ลคลิก Create Timing Constraints โปรแกรมจะทาํการสรางไฟล UCF – User Constraints 
File ขึ้นมา 

 
4. โปรแกรมจะถามวาตองการใหเชื่อมตอไฟล UCF นี้กบัโปรเจกเดิมหรือไม คลิกปุม Yes 

 
ไฟล count.ucf จะถูกสรางและเพิ่มเขามาทีโ่ปรเจกซึ่งสามารถดูไดที่หนาตาง Sources in Project 
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5. เลือกหนาตาง Xilinx Constraints Editor เลือกแท็บ Global ใสคาตางๆ ตอไปนี้สําหรับ CLOCK  
คาเหลานี้ควรจะสอดคลองกับคาที่กําหนดไวใน Period, Input Setup และ Output Delay ใน Test  

• Period: 40 ns 
• Pad to Setup: 10 ns 
• Clock to Pad: 10 ns 

 
6. ที่เมนูบาร คลิก File > Save 
7. ปดหนาตาง Xilinx Constraints Editor 
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การกําหนดตําแหนงขา (Pin Location) 
นอกเหนือจาก Timing Constraints แลว เราจะตองเลือกตําแหนงขาของอุปกรณใหกับอินพุทกบั
เอาทพุทที่ไดออกแบบ  โดยใหปฏิบัติดังตอไปนี ้
1. เลือกไฟล Count.ucf ในหนาตาง Sources in Project 
2. ในหนาตาง Processes for Source คลิกที่เครื่องหมาย “+” หนา User Constrints เพื่อขยายรายการ 
3. ดับเบิ้ลคลิกที่ Assign Package Pins โปรแกรมจะเปดหนาตาง Xilinx PACE (Pinout and Area 

Constraints Editor) ขึ้นมา 
4. เลือกขาตามรายการตอไปนี้ 

• CLOCK: p39 
• COUNT_OUT<0>: p38 
• COUNT_OUT<1>: p37 
• COUNT_OUT<2>: p36 
• COUNT_OUT<3>: p35 
• DIRECTION: p40 

หมายเหต:ุ ใหดูการเชื่อมตอสัญญาณของชุดคิททดสอบจากจากคูมือของ CPLD Explorer XC9572 

 
5. ที่เมนูบารเลือก File > Save 
6. โปรแกรมจะแสดงหนาตาง Bus Delimiter เพื่อใหเลือกชนิดของ Bus Delimiter ใหเลือก XST 
Default < > แลวคลิกปุม OK 
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7. ปดหนาตาง Xilinx PACE 

การ Synthesis and Implementation 
ขั้นตอนการ Synthesis และ Implementation มีดังตอไปนี้ 

• Synthesis with XST 
• FPGA Implementation: 
• Translate (which runs the NGDBuild program) 
• Map 
• Place and Route (PAR). 

ตอไปเราจะดําเนินการตามขัน้ตอนตอไปนี ้
1. เลือกไฟล Count.vhd ในหนาตาง Sources in Project 
2. ในหนาตาง Processes for Source คลิกที่เครื่องหมาย “+” หนา Implement Design เพื่อขยาย
รายการ 
3. ดับเบิ้ลคลิกที่ Implement Design ระบบจะดําเนินการ Translate, Map และ Place & Route ให
ตามลําดับ (ไมตองสนใจคําเตือนที่ Fit) 
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การโปรแกรมขอมูลวงจรลงชิพ CPLD 
เมื่อปรากฏเครื่องหมายถูกหนา Generate Programming File แสดงวาเราสามารถที่จะโปรแกรม
ขอมูลวงจรลงบนชิพ CPLD ไดแลว   โดยทีไ่ฟลขอมูลที่จะดาวนโหลดลงบนชิพจะเปนไฟล 
Bitstream หรือไฟลนามสกลุ .bit สําหรับ FPGA และไฟล Jedec หรือไฟลนามสกลุ .jed สําหรับ 
CPLD  ดังนัน้ในขั้นนี้ใหตรวจสอบดูใน Directory ของโปรเจกวาจะตองพบไฟล count.jed  การ
โปรแกรมขอมูลวงจรลงชิพ CPLD ใหทําดังตอไปนี ้
1. คลิกที่เครื่องหมาย “+” หนาคําวา Generate Programming File 
2. ดับเบิ้ลคลิกเมาสที่ Configure Device (iMPACT) 
3. โปรแกรมจะแสดงหนาตาง Configure Devices ใหเลือกอุปกรณโปรแกรมเปนประเภท 
Boundary-Scan Mode (JTAG) แลวคลิกปุม Next 



ISE Quick Start Tutorial with VHDL  20 

ผศ.ดร. อิทธิโชติ จักรไพวงศ  VHDL Tutorial 
คณะวิศวกรรมศาสตร มหาวิทยาลัยมหิดล   Last Updated 11/12/2006 

 
4. โปรแกรมจะแสดงหนาตาง Boundary-Scan Mode Selection ใหเลือก Automatically connect to 
cable and identify Boundary-Scan chain แลวคลิกปุม Finish 

 
5. โปรแกรมจะทําการตรวจหาชิพที่สาย JTAG เชื่อมตออยู ถาพบชิพโปรแกรมจะบอกโดยแสดง
หนาตาง Boundary-Scan Chain Contents Summary  คลิกปุม OK 
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6. เลือกไฟลที่โปรแกรมลงบนชิพ ซ่ึงในกรณีนี้จะสังเกตวาเปน CPLD ดังนั้นจึงตองใชไฟล .jed ให
เลือกไฟล count.jed แลวคลิกปุม Open  โปรแกรมจะแสดงหนาตาง Untitled [Configuration Mode] 
– iMPACT 

 
7. คลิกขวาที่ตัวไอซี แลวเลือกคลิกที่คําวา Program จะแสดงหนาตาง Program Options ไมตอง
เปลี่ยนแปลงตวัเลือกใดๆ คลิกปุม OK 

 
8. เมื่อเร่ิมทําการดาวนโหลด เมื่อดาวนโหลดเสร็จเรียบรอยโปรแกรมจะแสดงขอความที่หนาจอวา 
Programming Succeeded 
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ตอนนี้ไดทําการโปรแกรมขอมูลวงจรลงบนชิพเรียบรอยแลว ใหเราทดลองการทํางานของ
โปรแกรมโดยการกดปุม PB1 แทนสัญญาณนาฬิกา แลวปุม PB2 แทนทิศทาง จะพบวามันมัว่ๆ ไม
เปนตามที่เราคาดไว ขอใหลองทําการแกไขโปรแกรมจนใชไดถูกตอง 


